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Sound Byte is a computerized cart machine for the Macintosh. It is very 
similar to the so-called cart machines used at radio stations in the past. 
Each clip (recording) - a jingle, advertisement, etc, was on a cartidge, which 
could be quickly selected and played. Following this introduction are chapters 
that explain how to use and register (pay for) your copy of Sound Byte.

Sound Byte brings the cart machine to the computer age. You can assign 
select up to 75 recordings to a rack, and assign each to a button. Clicking on 
a button plays that recording. Multiple recordings can be played at the same 
time. 

Sound Byte comes in three versions:

Sound Byte Lite handles up to a single rack of carts, or 75 clips. The 
registration fee is only $24.

Sound Byte handles up to 5 racks of carts, or 375 clips.  The registration 
fee is only $49.

Sound Byte Pro a try, which supports up to 50 racks, or 3750 clips.  The 
registration fee is only $99.

Until you buy your copy, it will operate like the Lite version. In addition, the 
program will occasionally display reminder messages.

Sound Byte handles all of the audio formats supported by QuickTime, 
including:
AIFF
WAV



AU
MP3

If you'd like to create your own recordings, please give our program 
Audiocorder a try. It may be downloaded from the following URL:
http://www.blackcatsystems.com/software/audiocorder.html

Sound Byte is the perfect application to use whenever you need to quickly 
and easily play a variety of recorded sounds.

Possible Uses:
Radio Stations - jingles, advertisements, PSAs, songs, announcements, and 
more.

Plays and radio/TV productions - perfect for playing sound effects.

DJs - set up your play-list for the evening.

Sporting events - play sound effects when the home team scores, etc.



Insta l lat ion:

After unstuffing the download archive, you’ll have a folder containing the 
Sound Byte program, this documentation that you’re reading now,  an order 
form, as well as a folder called Racks. All of the racks that Sound Byte 
makes are stored in this folder, and it is very important that you keep it in 
the same location relative to Sound Byte. That is, if you move SoundByte, 
you need to move the Racks folder as well. 

If you want to put Sound Byte into the OS X Dock, make an alias of the 
program icon, and put the alias into the Dock. 



Main Window:

When you start the program, you'll see a window with 75 buttons, arranged in 
a 5 by 15 array. 

Each button represents one sound file (clip) that may be played.  This window 
is also called a “rack” - a term from back in older days of radio when 
recordings (songs, stations jingles, advertisements, etc) were all stored on 
cartridges, or carts for short. The carts were all kept on a rack. To play a 
song or ad, the DJ would grab the cart, plug it in, and play it. Many consoles 
allowed several carts to be queued up ahead of time, so the next one would 
always be ready to play. 

The top line of each button shows the title of the recording. By default it is 
the name of the file, but you can change it. Below this the length of the 
recording is shown, in Hours:Minutes:Seconds. At the bottom of the button is 



a volume control, so you can set the playback level for that particular 
recording. In the upper right corner of the button is an indicator that is 
normally black, and turns green when the recording is playing. Inside this, the 
hotkey character for the recording is shown. Each button can be assigned a 
hotkey, typing this key starts (or stops) the recording. You can also start a 
recording by clicking on the button. Click on the indicator, or the upper part 
of the button. Don’t click on the volume slider area. You can stop playback by 
clicking on the green indicator, or typing the hotkey again.

You can also navigate the carts by using the arrow keys. The up, down, left, 
and right keys will advance from the currently playing cart to the adjacent 
cart, and start it playing. You can also use the space bar to play the next (to 
the right) cart. This is handy if you need to play a sequence of carts in a row 
in order. Just set the up in the rack in the correct order, and hit the 
spacebar to start the next one. If you’re already in the right most column, 
hitting the space bar again will jump to the cart in the left most column of 
the next row.

If the buttons are too small, you can use the Change Cart Size item in the 
Edit menu to display fewer, but larger, carts. Carts to the right and bottom 
are not displayed. 

Here’s what a button looks like when the recording is playing:

The second line now shows the elapsed playback time, and the time 
remaining.

To assign a clip to a button, click on the button while holding down the 
command key. This will bring up the a small window called "Sound Clip Editor", 
shown below:



Clicking on the "Select Sound File..." button allows you to select the clip to 
associate with this button. If the file is grayed out in the open file dialog list, 
chances are the filetype is not set to one of those recognized by Sound Byte 
as a valid file. You can use ResEdit or another utility to change it. Filetypes 
recognized are: 

'AIFF'
'MooV'
‘Mp3 '
'MPEG'
'MPG3'
'sfil'
'Sd2f'
'ULAW'
'WAVE'
'????'

It’s always possible that the filetype of the recording file is not recognized 
by Sound Byte. You can try dragging the file onto an empty cart, and see if it 
is recognized.



The name of the file is automatically used as the button title. If you'd like to 
change the title, type the name you'd like to assign to this sound clip in the 
field called Title. You'll want do do this after you select the sound file, or the 
name you've typed in will get replaced by the name of the sound file, and 
you'll have to enter it in again.

If you select the Abort other sounds playing option, then whenever you 
play this sound, any other sounds that are currently playing will automatically 
be stopped. This can be much more convenient than having to manually stop 
the other sounds that may be playing.

If you select the Loop option, then when the sound is done playing, it will 
automatically be re-played.

If you select the Disable After Playing option, then when the sound is 
done playing, the cart will automatically be disabled. It will appear faded in the 
Rack, and you won’t be able to play it again until you’ve selected the Reset 
Disabled Carts option in the Edit menu. This is useful when you only want to 
play a sound once, and don’t want to accidently play it again, and want to 
make it so that unplayed sounds are more obvious in the Rack window.

You can also assign a hot key to this sound. This allows you to play the clip by 
just typing that key, without using the mouse. Hot key's may include the 
shift and option keys. 

Clicking on the "Set Button Color..." button lets you change the color of the 
button. This can be very handy if you want to color code buttons to make 
them easier to find. You'll get a color picker window, with lots of options, 
depending on which version of MacOS you're running. Select the color, then 
click on OK.

The Fade Rate field specifies how quickly the sound fades to silence when you 
select the Fade Current Cart item from the Edit menu. Larger numbers 
cause faster fades. A value of 4, for example, fades from maximum volume 
to complete silence in about 6 seconds. A value of 8 does the same fade in 
about 3 seconds. 

When you're done, click on the OK button.  Clicking on the Clear button will 
erase the button name and file association, essentially erasing the button 



entry.

Clicking on the Details button will bring up a window that allows the filename, 
as well as the volume number and parent ID of the recording file to be 
directly set. These should be changed only if you know what you are doing, 
and should be ignored by most users. It can be used if the volume (hard 
drived) used to store recording files gets assigned a new volume ID by the 
Macintosh operating system.

If you need the change the volume number for a lot of carts, select the 
Change File Info item in the Edit menu. You will get a window like that shown 
before. You enter in the old and new volume numbers, and all carts with the 
old volume number wil be changed to the new one. 

The easiest way to find out the correct new volume number is to add a sound 
file from the volume in question, and then check the details for it, to see 
what the volume number is. 



Clicking on the Mute button (or selecting Mute from the Edit menu, cmd-T) 
will mute any currently playing carts, which is handy during a voice-over, etc.

Also be sure to check the section on Preferences, which can set some useful 
features of Sound Byte.



Drag and Drop

You can also drag a suitable sound file into the button, which will assigned 
that sound file to the button. Grab the button in the lower right corner, on 
the little triangle. Drag it to the new location. 

Holding down the option key when you drop the file will change the file that is 
played, but keep the button color, text, hotkey, etc all the same. 

If you want to move buttons around (within the same rack), you can just drag 
one button on top of the other. They will automatically trade places.

Playing a Sound

To play a clip, just click on the button, or type the hot key. The indicator in 
the upper right of the button will turn green, to show that the clip is playing. 

Clicking on the indicator while the clip is still playing will stop playback. You 
can have more than one clip play at the same time.

You can stop all currently playing clips by pressing the ESC (escape) key.

If you’d like to start a cart at a particular time into the track, hold down the 
option key when you click on the button. You’ll see a dialog like this:

Enter in the start time in minutes:seconds and click OK. The cart will be 
started at that time, but in the paused mode. Unpause playing sounds (cmd-
U) to start it. You can of course queue up multiple carts at one time and 
then unpause all of them at once.



More About Racks

Under the Rack menu is a list of the racks available. To chose a new rack, 
just select it from the menu. The name of the rack can be changed by 
selecting “Rename...” from the Rack menu while that rack is the currently 
active window.

Your rack is automatically saved when you quit the program, or close it.

If instead of the volume slider, you’d rather see a progress bar showing the 
amount of the cart that has played so far, select Show Play Progress from 
the Edit menu. Each cart will now look like the following:

You can select Show Volume Sliders to get the sliders back, or select Show 
Nothing if you’d rather see neither.

Selecting Max All Volumes from the Edit menu will set all volume sliders to 
the maximum volume.

Selecting Fade Current Cart from the Edit menu will fade the volume of the 
currently playing cart over a few seconds. This operation of this function is 
undefined if you have more than one cart playing. You can select the fade 
rate for each cart by cmd-clicking on the cart to bring up the editing window 
for that cart.

Selecting Pause Playing Carts from the Edit menu will paue the playback of all 
active carts. Selecting it again will start them playing from were they left 
off.



Play List

The Play List allows you to select cuts to play ahead of time, organize them 
in a list, and control their playback.

For each recording in the playlist, the title (name of recording file), length in 
Hours : Minutes : Seconds is shown, as well as how much time into the 
playback session that recording will start. A small black dot appears to the 
right of the title of the active (currently playing or next to play) recording.

To create a play list, select New PlayList... from the File menu. You’ll be 
asked to name the play list. It will have one blank entry in it. This will be 
removed the first time you save and re-load the play list. 

You can drag a cart over to the play list window from a button on the main 
window, or you can drag a sound file over directly from Finder.  Drop it onto 
the “Drag Files Here” box to have them appended onto the end of the play 
list, or drag them into the position where you want them. You can always 
change the order of items in the play list up or down, by dragging the entries 
around.



You can then drag additional cuts over. Dragging them after cuts already in 
the play list schedules them later. Dragging them onto an existing scheduled 
cut schedules them before that cut.

You can delete a scheduled cut by selecting it, and typing cmd-X or selecting 
cut from the edit menu. You can can also re-arrange the order by dragging 
entries around.

You can also open an existing play list by selecting Open from the File menu, 
and then selecting the play list file. You can only have one play list open at a 
time.

The play list has seven buttons. Let’s go through them in order from left to 
right:

 Play - Clicking this button starts playback of the selected recordings, in 
order. A small dot is displayed next to the active (playing) cut.

 Stop - Clicking this button stops playback. Clicking Play again will start 
the active recording, at the beginning.

 Pause - Clicking this button pauses playback. Clicking Play will start it 
again, right where it left off, not at the beginning of the recording.

 Skip - Clicking this button will stop playback of the currently playing 
recording, and start playback of the next. Think of it as a way to abort a 
cut, and jump right to the next one.

 Loop - When depressed, the loop button will cause the playlist to start 
over again, after the last cut is finished.



 Rewind - Stops playback, and selects the first recording as the active 
recording. When play is clicked, the first recording will start playback.

 Play One Cut - Click once to select, again to de-select. When selected, 
only one recording will be played when Play is clicked. Pressing Play again will 
play the next recording. Useful to queue up several recordings in a row, and 
play them one by one, under your control as to when they start.  For 
example, sound effects for a play or other production, etc.

Your play list is automatically saved when you quit the program, or close it.



P re fe rences

The following preferences can be set:

Space skips to next cart
Hitting the spacebar will cause the next cart (to the right) to start playing.

Cart start aborts other carts playing
Starting a cart will stop any other playing cart(s)

Click on playing cart pauses playback instead of stopping it
Instead of stopping, a currently playing cart will pause when the cart button 
is clicked. Playback will resume when it is clicked again.

Fadeout cart rather than stopping it
Instead of abruptly stopping, a currently playing cart will fade out when 
another cart is started.



Buying Sound Byte

Sound Byte is distributed as shareware, if you continue to use it, you're 
required to register your copy. Until you register, the program will 
occasionally display reminder messages, and you'll be limited to ten minutes 
of use at a time.

By purchasing your copy of Sound Byte, you'll help support the program, and 
encourage the development of future releases. 

After buying, you'll be entitled to one year's worth of updates and new 
program versions.

The registration fees for each version are as follows:

Sound Byte Lite $24

Sound Byte $49

Sound Byte Pro $149

When you buy Sound Byte you'll receive a registration code, by email, usually 
within a few minutes. If you  don't get your registration code within a day or 
two, please send an email to: soundbyte@blackcatsystems.com.

If you want to use Sound Byte on multiple computers, you'll need to register 
a copy for each computer. If you'll be using Sound Byte on many computers, 
you may want to take a look at our site licensing options, which can save you 
a great deal of money.

Thanks again for giving Sound Byte a try.  

Black Cat Systems
4708 Trail Court
Westminster, MD 21158
USA

email:    info@blackcatsystems.com
Web:      http://www.blackcatsystems.com/software/soundbyte.html



Ordering by Check or Money Order

To order by check, please print, fill out and mail the following form, along with your payment. 
You can pay with a wide variety of cash from different countries but at present if you pay via 
check, it must be a check drawn in US Dollars. While there is the risk of loss in the mail, 
currency is also OK, including foreign currency.

Please make sure you include your email address with your payment. That way we can send the 
registration code to you, so you must include your email address. If you do not send us a valid 
email address, we have no way to send you the code. Please write clearly.

I would like to buy ____ copies of Sound Byte Lite, at $24 US per copy.

I would like to buy ____ copies of Sound Byte, at $49 US per copy.

I would like to buy ____ copies of Sound Byte Pro, at $99 US per copy.     

__ I would also like a CDROM with a copy of all of Black Cat Systems software, including Sound 
Byte, for $10 including shipping.

Email Address: ______________________________________________

Name: ___________________________________________________

Address: __________________________________________________

City: _______________________   State/Province:_________________

ZIP/Postal Code: __________________  Country: ___________________

Macintosh Model: _______________________ System Version: _________

Enclosed, please find my check / money order / cash in the amount of $_______
Maryland Residents please add 5% sales tax.

All payments must be in either checks/money orders in US dollars drawn on a US Bank, or an 
International Money Order. If this is inconvenient, or you would like to order with a credit card, 
please order online at http://www.blackcatsystems.com/register/soundbyte.html

Mail this form, along with payment, to:

Black Cat Systems
4708 Trail Court
Westminster, MD 21158
USA



Ordering Online By Credit Card

To order online with a credit card, go to the following URL:
http://www.blackcatsystems.com/register/soundbyte.html

Please make sure you include your email address when you orer online. That 
way we can send the registration code to you, so you must include your 
email address. If you do not send us a valid email address, we have no way to 
send you the code.



Ordering by Credit Card Using the Register Program

If you'd like to order by credit card online (the quickest way to get your 
registration code back), then please go to the previous chapter.

To mail or email in your credit card order, open the Register program that 
accompanies Sound Byte. Enter your name, your email address, and the 
number of single user licenses you desire for each program you wish to 
purchase. Save or Copy or Print the data from the Register program and 
send the data and payment to Kagi at sales@kagi.com. More specifics on the 
Register program to follow. Kagi handles my payment processing.

If paying with Credit Card , you can email or fax the data to Kagi. Their email 
address is sales@kagi.com and their fax number is +1 510 652-6589. You 
can either Copy the data from Register and paste into the body of an email 
message or you can Save the data to a file and you can attach that file to an 
email message. There is no need to compress the data file, it's already 
pretty small. If you have a fax modem, just Print the data to the Kagi fax 
number. 

Payments sent via email are processed within 3 to 4 days. You will receive an 
email acknowledgement when it is processed. Payments sent via fax take up 
to 10 days and if you provide a correct internet email address you will 
receive an email acknowledgement. 

If you are mailing your credit card payment to Kagi, send it to: 

              Kagi
              1442-A Walnut Street #392-SZ
              Berkeley, California 94709-1405
              USA

Please make sure you include your email address with your payment. That 
way we can send the registration code to you. You must include your email 
address. If you do not send us a valid email address, we have no way to send 
you the code.



Entering Your Registration Code

When you register Sound Byte, you'll receive an email containing your 
registration code. Select Register... from the File menu, and enter the 
code into the window that appears, along with your Name and Email address 
(optional):

 
Please be sure to enter your name and registration code exactly as shown 
in the registration email you received. Your code is locked to your name.



Sound Byte Version History

2.7.1 - March 26, 2006
Fixed a bug that could cause a crash when opening a Rack.

2.7.0 - January 8, 2006
Mute feature, kill sound output for voice-overs, etc.
Added preferences option for spacebar to play the next cart
Added preferences option to abort other playing carts when playing a new 
one
Added preferences option to pause playback of carts
Added preferences option to fade carts out 
Fixed a bug that could cause a crash if the Playlist window is used without a 
Rack window being open.

2.6.3 - October 7, 2005
Fixed a bug that could cause Sound Byte to crash when started up, if no Rack 
files exist. 

2.6.2 - October 7, 2005
Fixed a bug on systems with multiple volumes, where Sound Byte could lose 
track of sound files stored on volumes other than the startup volume. 

2.6.1 - September 27, 2005
Fixed a bug that could cause long waits when adding sounds.

2.6.0 - August 29, 2005
Added large display of details on the currently playing cart.
Enlarged the size of the displayed hotkey for better visibility.
Added feature to change volume numbers for all recording files in a rack.
Added a hot spot in the PlayList window in which to drop recordings.
Fixed a bug with fading - if a cart finished playing wile fading, the next cart 
played would start fading.
Some Tiger Mac OS X 10.4 related bug fixes.



2.5.0 - February 14, 2005
Auto-set cart size when a rack is opened.
Can now use space bar and arrow keys to navigate carts.

2.4.0 - February 14, 2005
Added the ability to display fewer but larger carts, for increased visibility.
Fade times can now be programmed individually for each cart.
Carts can be set to be disabled after being played, to make it easier to 
identify carts that have not been played yet.
Removed being able to click anywhere on cart to stop playback as it caused 
the sound to stop playing if you adjusted the volume. Now you need to click in 
the upper part of the cart button, where the title and playing time are 
located.

2.3.0 - November 4, 2004
Can now click anywhere on cart to stop playback.
Can now clear entries in Playlist window.

2.2.0 - May 12, 2004
Can pause the playback of currently playing carts.
Can start a cart at a particular time into the recording.
Can now drop multiple files into a rack at the same time.
Can clear all entries in a rack.
Volume indicators and progress displays for unused carts not shown.
After a fade, cart volume is now returned to previous setting.
Added checking for latest version and visiting website to About menu.
When a cart is dragged, the color now correctly updates immediately.

2.1.0 - March 4, 2004
Added the ability to fade the currently playing track.
Added display showing the elapsed time of currently playing tracks.
Added the ability to change the volume ID for cart recording files.

2.0.2 - February 6, 2003
Added ‘Sd2f’ and ‘MPG3’ filetypes to those recognized as valid sound files.



2.0.1 - January 12, 2003
Bug fix - couldn’t click on carts.

2.0.0 - January 11, 2003
Bug fix - couldn’t access sliders on bottom row of rack
Preferences menu item disabled (there are no preferences)

2.0.0b2 - November 30, 2002
Fixed bugs with saving play lists
Fixed bugs that could cause a crash when closing a rack
Fixed bugs with play list buttons
Fixed bugs with dragging clips

2.0.0b1 - First release of Mac OS X test version



Sound Byte Version History

Software License Agreement
This is a legal agreement between you and Black Cat Systems. covering your use of Sound Byte 
(the "Software"). Be sure to read the following agreement before using the Software. BY USING 
THE SOFTWARE (REGARDLESS IF YOU HAVE REGISTERED THE SOFTWARE OR 
NOT), YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT. IF 
YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO NOT USE THE 
SOFTWARE AND DESTROY ALL COPIES IN YOUR POSSESSION.

The Software is owned by Black Cat Systems and is protected by United States copyright laws and 
international treaty provisions. Therefore, you must treat the Software like any other copyrighted 
material (e.g., a book or musical recording). Paying the license fee allows you the right to use one 
copy of the Software on a single computer. You may not network the Software or otherwise use it 
or make it available for use on more than one computer at the same time. You may not rent or lease 
the Software, nor may you modify, adapt, translate, reverse engineer, decompile, or disassemble the 
Software. If you violate any part of this agreement, your right to use this Software terminates 
automatically and you must then destroy all copies of the Software in your possession.

The Software and its related documentation are provided "AS IS" and without warranty of any kind 
and Black Cat Systems expressly disclaims all other warranties, expressed or implied, including, but 
not limited to, the implied warranties of merchantability and fitness for a particular purpose. Under 
no circumstances shall Black Cat Systems be liable for any incidental, special, or consequential 
damages that result from the use or inablility to use the Software or related documentation, even if 
Black Cat Systems has been advised of the possibility of such damages. In no event shall Black Cat 
Systems's liability exceed the license fee paid, if any.

This Agreement shall be governed by the laws of the State of Maryland. If for any reason a court of 
competent jurisdiction finds any provision of the Agreement, or portion thereof, to be 
unenforceable, that provision of the Agreement shall be enforced to the maximum extent 
permissible so as to effect the intent of the parties, and the remainder of this Agreement shall 
continue in full force and effect.

The Software and documentation is provided with RESTRICTED RIGHTS. Use, duplication, or 
disclosure by the Government is subject to restrictions as set forth in subdivision (b)(3)(ii) of the 
Rights in Technical Data and Computer Software clause as 252.227-7013.  Manufacturer is Black 
Cat Systems., 4708 Trail Court, Westminster, MD 21158, United States of America. 

The name "Black Cat Systems", and  "Sound Byte" are trademarks of Black Cat Systems.

Sound Byte is ©1997-2006 by Black Cat Systems. All rights reserved worldwide.
Created with MacZoop by Graham Cox, ©1994-2003 All Rights Reserved.


